AWS outage affecting Practice Management Bridge and Phone System

Incident Report for Rectangle Health

Resolved

Rectangle Health's Phone System is now fully operational. AWS has reported all services have been fully resolved.
Posted Oct 20, 2025 - 23:51 UTC

Update

Our Phone System continues to experience issues related to the AWS outage. Our team is still here to support you — please reach out via care@rectanglehealth.com for assistance.
Posted Oct 20, 2025 - 20:17 UTC

Update

We are still monitoring the AWS status of their impacted services. We are seeing functionality restored to our Payments and Engagement products. We continue to monitor the Phone System as our provider is dependent on AWS.
Posted Oct 20, 2025 - 19:31 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 17:43 UTC

Identified

Due to widespread AWS issues, Practice Management Bridge and our phone system are currently experiencing partial outages. Our team is still here to support you — please reach out via care@rectanglehealth.com for assistance.
Posted Oct 20, 2025 - 16:48 UTC
This incident affected: Bridge Payments 3.0 (Bridge Payments, Balance Collect, Patient Express, Recurring Payments API, Forms), Bridge Engagement Pro / Premium (Engagement Pro/Premium - Application, Engagement Pro/Premium - Reminders), Rectangle Health Phone System (Talkdesk Inbound Calls (Talkdesk Voice)), Rectangle Health Technology Partner API (Horizon Payments, Horizon Reporting), and PayerSync (PayerSync payment processing).