All payment processing impacted

Incident Report for Rectangle Health

Resolved

This incident is resolved. If you have any other questions or concerns, please contact Rectangle Health Support at support@Rectanglehealth.com
Posted Feb 24, 2025 - 21:38 UTC

Identified

Rectangle Health Engineering has identified the issue and is working to implement a fix.

The next update will be available by 5:00pm EST.
Posted Feb 24, 2025 - 21:32 UTC

Update

We are continuing to investigate this issue.
Posted Feb 24, 2025 - 20:36 UTC

Update

We are continuing to investigate this issue.
Posted Feb 24, 2025 - 20:13 UTC

Investigating

Rectangle Health Engineering is actively investigating an issue that is impacting payment processing.

If you have any further questions or concerns, please open a ticket with Rectangle Health Support at support@rectanglehealth.com. Thank you for your patience as we actively work to resolve this issue.

The next update will be available by 4:00pm EST.
Posted Feb 24, 2025 - 20:13 UTC
This incident affected: Bridge Payments 3.0 (Bridge Payments, Balance Collect).