This incident is resolved. If you have any other questions or concerns, please contact Rectangle Health Support at support@Rectanglehealth.com
Posted Feb 24, 2025 - 19:02 UTC
Monitoring
Rectangle Health Engineering has successfully implemented a fix, and we are currently monitoring the results.
Posted Feb 24, 2025 - 18:40 UTC
Update
Rectangle Health Engineering is still actively investigating an issue that is impacting payment processing and application functionality.
If you have any further questions or concerns, please open a ticket with Rectangle Health Support at support@rectanglehealth.com. Thank you for your patience as we actively work to resolve this issue.
The next update will be available by 1:30pm EST.
Posted Feb 24, 2025 - 17:30 UTC
Update
Rectangle Health Engineering is still investigating an issue that is impacting payment processing and functionality of the application.
If you have any further questions or concerns, please open a ticket with Rectangle Health Support at support@rectanglehealth.com. Thank you for your patience as we actively work to resolve this issue.
Posted Feb 24, 2025 - 16:33 UTC
Update
We are continuing to investigate this issue.
Posted Feb 24, 2025 - 15:32 UTC
Investigating
Rectangle Health Engineering is actively investigating an issue that is impacting payment processing.
If you have any further questions or concerns, please open a ticket with Rectangle Health Support at support@rectanglehealth.com. Thank you for your patience as we actively work to resolve this issue.
The next update will be available by 11:30am EST.
Posted Feb 24, 2025 - 15:31 UTC
This incident affected: Bridge Payments 3.0 (Bridge Payments, Balance Collect).