Balance Collect Payments impacted

Incident Report for Rectangle Health

Resolved

This incident is resolved. If you have any other questions or concerns, please contact Rectangle Health Support at care@Rectanglehealth.com
Posted Sep 29, 2025 - 16:00 UTC

Monitoring

Rectangle Health Engineering has successfully implemented a fix, and we are currently monitoring the results.
Posted Sep 29, 2025 - 15:24 UTC

Identified

Rectangle Health Engineering has identified an issue that is impacting Balance Collect payment processing. We are actively working on a fix for this environment.

The next update will be available by 11:40am ET
Posted Sep 29, 2025 - 15:09 UTC

Investigating

Rectangle Health Engineering is actively investigating an issue that is impacting Balance Collect payment processing.

The next update will be available by 11:30am ET.
Posted Sep 29, 2025 - 14:58 UTC
This incident affected: Bridge Payments 3.0 (Balance Collect).