Partial payment processing impacted

Incident Report for Rectangle Health

Update

Restoration of Practice Management Bridge continues. Practices will receive an email notification once their activation has been restored. Until then, please continue using the Virtual Terminal to accept payments. Instructions can be found here
Posted Mar 10, 2026 - 14:35 UTC

Update

Restoration of Practice Management Bridge is progressing successfully, and service is continuing to be restored. Until you are notified that Practice Management Bridge is restored for your practice, please continue to use the Virtual Terminal to accept payments. Instructions can be found here
Posted Mar 05, 2026 - 16:16 UTC

Update

Practice Management Bridge system restoration is underway. Until you are notified that Practice Management Bridge is restored for your practice, please continue to use the Virtual Terminal to accept payments. Instructions can be found here
Posted Feb 26, 2026 - 20:15 UTC

Update

Rectangle Health is planning to activate a new solution next week. Connection details are being finalized and will involve a new gateway approach. Your Virtual Terminal remains available and information can be found here.

Instructions outlining activation timing and next steps will be shared next week.*

Note: Standalone terminal only customers not utilizing our Practice Management Bridge software are not affected.

*This communication reflects current information and remains subject to change as work progresses.
Posted Feb 20, 2026 - 19:45 UTC

Update

Rectangle Health continues to work toward restoring services impacted by the BridgePay Network Solutions (BNS) gateway outage. We are focusing on security, compliance, and long‑term reliability. Your temporary Virtual Terminal remains a secure option for payment collection. We plan to share an update by the end of this week, with restoration anticipated next week pending completion of required testing and validation.*
Instructions available here.

*This communication reflects current information and remains subject to change as work progresses.
Posted Feb 18, 2026 - 16:00 UTC

Update

Temporary payment solutions, including secure manual entry (virtual terminal), are available to help you continue collecting payments. Instructions available here.
Our teams are working continuously to support customers affected by this incident at our third-party vendor.

We appreciate your patience and will update this page as new information becomes available.
Posted Feb 13, 2026 - 20:00 UTC

Update

Our engineering teams are actively implementing temporary mitigation strategies to reduce the impact of our vendor’s outage and restore services. We continue to coordinate with our vendor to fully restore the outage. Customer resources are available here
Next update will be at 3pm ET
Posted Feb 13, 2026 - 17:00 UTC

Update

Our engineering teams are actively implementing temporary mitigation strategies to reduce the impact of our vendor’s outage and restore services. We continue to coordinate with our vendor to fully restore the outage. Customer resources are available here
Next update will be at Noon ET
Posted Feb 13, 2026 - 14:00 UTC

Update

Our engineering teams are actively implementing temporary mitigation strategies to reduce the impact of our vendor’s outage and restore services. We continue to coordinate with our vendor to fully restore the outage. Customer resources are available here
Next update will be at 9am ET
Posted Feb 13, 2026 - 02:01 UTC

Update

Our engineering teams are actively implementing temporary mitigation strategies to reduce the impact of our vendor’s outage and restore services. We continue to coordinate with our vendor to fully restore the outage. Customer resources are available here
Next update will be at 9pm ET
Posted Feb 12, 2026 - 23:00 UTC

Update

Our engineering teams are actively implementing temporary mitigation strategies to reduce the impact of our vendor’s outage and restore services. We continue to coordinate with our vendor to fully restore the outage. Customer resources are available here
Next update will be at 6pm ET
Posted Feb 12, 2026 - 20:00 UTC

Update

Our engineering teams are actively implementing temporary mitigation strategies to reduce the impact of our vendor’s outage and restore services. We continue to coordinate with our vendor to fully restore the outage. Customer resources are available here
Next update will be at 3pm ET
Posted Feb 12, 2026 - 16:59 UTC

Update

We have activated temporary access measures to reduce the impact of our vendor’s outage and are continuing to work with the vendor to fully restore services. Please access customer resources here
Next update will be at Noon ET
Posted Feb 12, 2026 - 13:59 UTC

Update

We have activated temporary access measures to reduce the impact of our vendor’s outage and are continuing to work with the vendor to fully restore services. Please access customer resources here
Next update will be at 9am ET
Posted Feb 12, 2026 - 02:00 UTC

Update

We have activated temporary access measures to reduce the impact of our vendor’s outage and are continuing to work with the vendor to fully restore services. Please access customer resources here
Next update will be at 9pm ET
Posted Feb 11, 2026 - 23:00 UTC

Update

Our engineering teams are actively implementing temporary mitigation strategies to reduce the impact of our vendor’s outage and restore services. We continue to coordinate with our vendor to fully restore the outage. Customer resources are available here
Next update will be at 6pm ET
Posted Feb 11, 2026 - 19:59 UTC

Update

Our engineering teams are actively implementing temporary mitigation strategies to reduce the impact of our vendor’s outage and restore services. We continue to coordinate with our vendor to fully restore the outage. Customer resources are available here
Next update will be at 3pm ET
Posted Feb 11, 2026 - 16:59 UTC

Update

Our engineering teams are actively implementing temporary mitigation strategies to reduce the impact of our vendor’s outage and restore services. We continue to coordinate with our vendor to fully restore the outage. Customer resources are available here
Next update will be at Noon ET.
Posted Feb 11, 2026 - 14:00 UTC

Update

Our engineering teams are actively implementing temporary mitigation strategies to reduce the impact of our vendor’s outage and restore services. We continue to coordinate with our vendor to fully restore the outage. Customer resources are available here
Next update will be at 9am ET.
Posted Feb 11, 2026 - 01:59 UTC

Update

Our engineering teams are actively implementing temporary mitigation strategies to reduce the impact of our vendor’s outage and restore services. We continue to coordinate with our vendor to fully restore the outage. Customer resources are available here
Next update will be at 9pm ET.
Posted Feb 10, 2026 - 22:59 UTC

Update

Our engineering teams are actively implementing temporary mitigation strategies to reduce the impact of our vendor’s outage and restore services. We continue to coordinate with our vendor to fully restore the outage. Customer resources are available here
Next update will be at 6pm ET.
Posted Feb 10, 2026 - 20:51 UTC

Update

Our engineering teams are actively implementing mitigation strategies to reduce impact and restore services while we continue coordinating with our vendor.
Next update will be at 6pm ET
Posted Feb 10, 2026 - 20:01 UTC

Update

Our engineering teams are actively implementing mitigation strategies to reduce impact and restore services while we continue coordinating with our vendor.
Next update will be at 3pm ET
Posted Feb 10, 2026 - 17:00 UTC

Update

Our engineering teams are actively implementing mitigation strategies to reduce impact and restore services while we continue coordinating with our vendor.
Next update will be at Noon ET
Posted Feb 10, 2026 - 14:00 UTC

Update

Our engineering teams are actively implementing mitigation strategies to reduce impact and restore services while we continue coordinating with our vendor.
Next update will be at 9pm ET
Posted Feb 09, 2026 - 23:04 UTC

Update

Our engineering teams are actively implementing mitigation strategies to reduce impact and restore services while we continue coordinating with our vendor.
Next update will be at 6pm ET
Posted Feb 09, 2026 - 20:09 UTC

Update

Our engineering teams are actively implementing mitigation strategies to reduce impact and restore services while we continue coordinating with our vendor.
Next update will be at 3pm ET
Posted Feb 09, 2026 - 16:56 UTC

Update

Our engineering teams are actively implementing mitigation strategies to reduce impact and restore services while we continue coordinating with our vendor.
Next update will be at Noon ET
Posted Feb 09, 2026 - 14:12 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at Noon ET
Posted Feb 09, 2026 - 14:05 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at 9am ET, Monday 2/9
Posted Feb 08, 2026 - 21:59 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at 5pm ET
Posted Feb 08, 2026 - 17:00 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at Noon ET
Posted Feb 08, 2026 - 14:00 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at 9am ET, Sunday 2/8
Posted Feb 07, 2026 - 22:04 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at 5pm ET
Posted Feb 07, 2026 - 16:58 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at Noon ET
Posted Feb 07, 2026 - 13:58 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at 9am ET, Saturday 2/7
Posted Feb 07, 2026 - 03:00 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at 10pm ET
Posted Feb 07, 2026 - 02:00 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at 9pm ET
Posted Feb 07, 2026 - 01:02 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at 8pm ET
Posted Feb 07, 2026 - 00:01 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at 7pm ET
Posted Feb 06, 2026 - 22:59 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at 6pm ET
Posted Feb 06, 2026 - 22:05 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at 5pm ET
Posted Feb 06, 2026 - 21:02 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at 4pm ET
Posted Feb 06, 2026 - 20:03 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at 3pm ET
Posted Feb 06, 2026 - 19:03 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at 2pm ET
Posted Feb 06, 2026 - 18:05 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at 1pm ET
Posted Feb 06, 2026 - 17:00 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update will be at Noon ET.
Posted Feb 06, 2026 - 16:03 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update at 11am ET
Posted Feb 06, 2026 - 15:00 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Next update at 10am ET
Posted Feb 06, 2026 - 14:04 UTC

Update

We are continuing to monitor our communication channels with our gateway vendor for this issue.
Posted Feb 06, 2026 - 13:15 UTC

Identified

The issue has been identified with our downstream gateway processor. They are aware of the issue, however no ETA has been provided for the issue.
Posted Feb 06, 2026 - 12:16 UTC

Investigating

Rectangle Health Engineering is actively investigating an issue that is impacting payment processing.

The next update will be available by 8am ET.
Posted Feb 06, 2026 - 12:07 UTC
This incident affects: Bridge Payments 3.0 (Bridge Payments, Balance Collect, Patient Express, Integration Engine, Recurring Payments API, Wallet API, PayGuardian Cloud API, TokenPay API, Transaction API, Transaction Reporting API, User/Credential Management API) and Rectangle Health Technology Partner API (Horizon Payments, TPP Wallet API, TPP PayGuardian Cloud API, TPP TokenPay API, TPP Transaction API, TPP Transaction Reporting API, TPP User/Credential Management API).