All payment processing impacted

Incident Report for Rectangle Health

Resolved

This incident is resolved. If you have any other questions or concerns, please contact Rectangle Health Support at care@Rectanglehealth.com
Posted Apr 22, 2025 - 19:26 UTC

Monitoring

Rectangle Health Engineering has successfully implemented a fix, and we are currently monitoring the results.
Posted Apr 22, 2025 - 19:18 UTC

Identified

Rectangle Health Engineering has identified the issue and is working to implement a fix.

The next update will be available by 3:45pm ET.
Posted Apr 22, 2025 - 19:15 UTC

Update

Rectangle Health Engineering continues to investigate an issue that is impacting payment processing and customer logins.
The next update will be available by 3:30pm EDT.
Posted Apr 22, 2025 - 18:59 UTC

Update

Rectangle Health Engineering continues to investigate an issue that is impacting payment processing and customer logins.
The next update will be available by 3:00pm EDT.
Posted Apr 22, 2025 - 18:31 UTC

Update

Rectangle Health Engineering continues to investigate an issue that is impacting payment processing and customer logins.
The next update will be available by 2:30pm EDT
Posted Apr 22, 2025 - 18:02 UTC

Update

Rectangle Health Engineering continues to investigate an issue that is impacting payment processing and customer logins.
The next update will be available by 2:00pm EDT.
Posted Apr 22, 2025 - 17:32 UTC

Update

Rectangle Health Engineering continues to investigate an issue that is impacting payment processing and customer logins.
The next update will be available by 1:30pm EDT.
Posted Apr 22, 2025 - 17:03 UTC

Update

Rectangle Health Engineering continues to investigate an issue that is impacting payment processing and customer logins.
The next update will be available by 1:00 pm EDT.
Posted Apr 22, 2025 - 16:31 UTC

Update

Rectangle Health Engineering continues to investigate an issue that is impacting payment processing and customer logins.
The next update will be available by 12:30pm EDT.
Posted Apr 22, 2025 - 16:03 UTC

Update

Rectangle Health Engineering is actively investigating an issue that is impacting payment processing and customer logins.

The next update will be available by Noon ET.
Posted Apr 22, 2025 - 15:34 UTC

Investigating

Rectangle Health Engineering is actively investigating an issue that is impacting payment processing and customer logins.

The next update will be available by Noon ET.
Posted Apr 22, 2025 - 15:27 UTC
This incident affected: Bridge Payments 3.0 (Bridge Payments, Balance Collect).